Announcement

Collapse
No announcement yet.

Olympus C-740UZ

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Olympus C-740UZ

    G'day,

    Excuse me if I'm posting in the wrong part of the forum. I recently bought an Olympus C-740UZ off a friend from HK, I have looked at it and it worked fine for as long as it was with my friend.

    I brought it back to Australia a week ago and tried to take a few photos. At first everything was fine until the batteries went empty and the camera switched off for some reason without the lense retracting. I changed batteries but the lens keep staying in the same position, so I tried to take some photos but it didn't take any, tried to zoom but didn't zoom at all, all it made was a little 'click' noise from the lens everytime I tried to zoom or take a photo. I've used brand new batteries but it still keeps saying the batteries are low and then empty.

    Right now, the camera is off and the lens are still out. Have no idea what's going wrong with it, the card is empty. Perhaps I did a wrong setting maybe?

    Sorry for the long post, your inputs and help would be greatly appreciated!

    Regards,

    TOGA

  • #2
    Hi TOGA-
    I used to have an Olympus C-730uz & when my batteries went dead the lens would always retract (and never made any clicking noises). I think your best shot would be contacting Olympus & maybe sending it in if they can't do anything over the phone.

    Justin
    Click below.

    [http://www.jetphotos.net/showphotos.php?userid=3669]

    Comment


    • #3
      I have a C-740, Yes, yours sounds like it needs to be fixed.


      Comment

      Working...
      X